Register now on PaFlyFish.com! Login
HOME FORUM BLOG PHOTOS LINKS


Sponsors

Browsing this Thread:   1 Anonymous Users



(1) 2 3 »


Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
I just picked up this rod on Friday. I used it each day and tonight I noticed this. The tape (????) around the rod guides and at the ends where the sections connect have turned white and are sticky. When touched the white stuff pulls and moves and comes off.

It is a Orvis Clearwater II 7'6"-3wt purchased from Mainstream outfitters (Daves sporting center) in Doylestown.

Is this normal??


Attach file:



jpg  rod-guide.jpg (91.83 KB)
6310_4f8b686b6d508.jpg 727X545 px

jpg  rod-guide2.jpg (144.05 KB)
6310_4f8b687916103.jpg 869X1158 px

Posted on: 2012/4/15 20:31


Re: Problem with my new rod photos

Joined:
2010/5/30 18:53
From Spring Grove, Pa
Posts: 257
Offline
Iwould say that is not normal at all. Orvis backs their rods good. I would take it back to the place that you purchased it.

Posted on: 2012/4/15 20:38


Re: Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
Quote:

RonB wrote:
Iwould say that is not normal at all. Orvis backs their rods good. I would take it back to the place that you purchased it.


I didn't think so.. Im really not happy. I hope they make good on this and don't make me ship this thing since Its only 3 days old. Now I just read the warranty on the orvis site. For a "nominal $30 fee they will repair the rod. I really hope I don't have to go that route since I paid $140 for it 3 days ago.

Posted on: 2012/4/15 20:44


Re: Problem with my new rod photos

Joined:
2010/5/30 18:53
From Spring Grove, Pa
Posts: 257
Offline
I just purchased a Orvis Clearwater II a month or two ago and it has done nothing like that. It appears to me that the finish over the wraps on the guides never cured properly

Posted on: 2012/4/15 20:47


Re: Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
Does anyone think i should have to pay $30 to get it repaired?

Posted on: 2012/4/15 20:49


Re: Problem with my new rod photos

Joined:
2010/5/28 0:25
Posts: 590
Offline
Call Orvis. I would be shocked if they didn't warrant it without cost to you, since you only owned it 3 days with an apparent manufacturing defect.

Posted on: 2012/4/15 21:09


Re: Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
Quote:

outsider wrote:
Call Orvis. I would be shocked if they didn't warrant it without cost to you, since you only owned it 3 days with an apparent manufacturing defect.


Ok I agree. I hope I can get this resolved through Mainstream outfitters (Daves sporting center) in Doylestown since its brand new. We'll see, no reason to worry I'm sure it will all work out. If i have to send it to orvis, it could take 3 to 6 weeks to get it back.

Posted on: 2012/4/15 21:17


Re: Problem with my new rod photos

Joined:
2010/5/28 0:25
Posts: 590
Offline
pm sent

Posted on: 2012/4/15 21:37


Re: Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
Let me clarify one thing before I make any calls. My rod did go under the water today when i was fishing. I had the rod between my legs while taking a photo of a sunfish. So more than 3/4 of the rod went under. Would getting the rod wet like this cause such problems? Did I make a mistake?

Posted on: 2012/4/15 21:43


Re: Problem with my new rod photos

Joined:
2010/5/28 0:25
Posts: 590
Offline
shoud make no diference at all. Rods get wet. looking at picture is speculative, but by your accounts, it look likes poorly make wraps, AKA a manufacturig defect.

Posted on: 2012/4/15 22:06


Re: Problem with my new rod photos

Joined:
2010/5/28 0:25
Posts: 590
Offline
shoud make no diference at all. Rods get wet. looking at picture is speculative, but by your accounts, it look likes poorly make wraps, AKA a manufacturig defect.

Posted on: 2012/4/15 22:06


Re: Problem with my new rod photos

Joined:
2012/1/9 19:50
From Etters,Pa
Posts: 723
Offline
Quote:
by Pauly on 2012/4/15 21:43:47 Let me clarify one thing before I make any calls. My rod did go under the water today when i was fishing. I had the rod between my legs while taking a photo of a sunfish. So more than 3/4 of the rod went under. Would getting the rod wet like this cause such problems? Did I make a mistake?


If your not getting it wet your not fishing. I lost a custom Fenwick rod in the river once for 5 months till water levels receded. When I found the rod it was dirty but in perfect condition. Don't you dare pay a penny for a replacement. Make sure you let us know how you make out.

Posted on: 2012/4/15 22:11


Re: Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
Yeah I just checked on it. The sealant is not white any more but it is sticky. The rod sections are sticking to my clear coat maple work bench. I bought Orvis thinking I was moving up in the world.

Posted on: 2012/4/15 22:44


Re: Problem with my new rod photos

Joined:
2012/4/8 10:21
From Perkasie, PA
Posts: 101
Offline
Update
Monday 8:07am. Called orvis and explained the defect and my concerns about paying $30 for repair fee and being without a rod for 3 to 6 weeks.

They replied that the problem is not typical and would wave the $30 fee. Also, they would overnight a new replacement rod a newer model once they received my rod. Or they would send one now if I really needed it. I told them to ship the rod once they get mine and can verify the problem I explained.

So I mailed the rod at 9:02 am via USPS priority mail which should be there on Wednesday.

So far I am satisfied with Orvis's and how they are taking care of this. I'm not so happy with the $13 out of pocket shipping charge; however, I am willing to deal with it since a trip to the mainstream outfitters would have taken up fuel and time: besides their not open on Monday. And I already have a good answer so far!

I will update this just so we can all see the actual outcome.

Posted on: 2012/4/16 10:41


Re: Problem with my new rod photos

Joined:
2007/6/9 10:11
Posts: 216
Offline
I'd have taken it to daves personally. They should have swapped it out and dealt with orvis. I know orvis would make it good. They get hosed on people treating their waders like loaners to be sent back after years of service. Looked to me like it was a bad epoxy mix. I've screwed up proportions coating wraps and had to take it off as they would not harden up.

Posted on: 2012/4/16 11:04



(1) 2 3 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]





Site Content
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Stay Connected

twitterfeed.com facebook instagram RSS Feed

Sponsors
Polls
Will you be fly fishing this autumn?
Yes 95% (139)
No 0% (0)
Thinking about it 4% (6)
_PL_TOTALVOTES
The poll closed at 2014/10/31 17:56
1 Comment





Copyright 2014 by PaFlyFish.com | Privacy Policy| Provided by Kile Media Group | Design by 7dana.com